Ask here your questions to get help using GDevelop.
By LudicrousExplosion
#70595 Hi gdevelopers,

I've created a standalone android apk.
Like I did 30 times before, for the same project.
using Export project to standalone game: Package for Android

After uploading to Google Play I get the following error:
Upload failed
You uploaded a debuggable APK or Android App Bundle. For security reasons you need to disable debugging before it can be published in Google Play. Find out more about debuggable APKs or Android App Bundles.

You uploaded an APK that is not signed with the upload certificate. You must use the same certificate. The upload certificate has fingerprint:

I got this error once before, then I tried the next day, and everything worked.

No I'm waiting and sending my project to the build server every few hours for a few days, but no success.

What can be the problem? Is the build server just compiling in debug mode?

All help appreciated,

game: Santa, Penguin Hunter (previous version is on play store :-) )
User avatar
By xisco
#70613 Hi,
happened the same to me some days ago, compiled again with GDevelop and google didn't say anything.
Maybe something went wrong on the previous compilation :?
I use export to android option. Are you using Gdevelop 5 beta? I am and maybe was an issue with the version, now I'm with beta 64.

User avatar
By xisco
#70651 Hi again!!
Last night I had the same problem again, compiled with GDevelop twice and tried several times PhoneGap build, always the same error.
You are right should be a problem from google. The message says something about signature of file, but google is administering my keys to sign files :?
I'll try to contact google, and write here any news.
User avatar
By xisco
#70662 hi
I did some research and digging so, bad news: google is right.
I found a tool called apktool to decompile the apk and androidmanifest xml contains a section debuggable=true, so I know wkhat google will answer me. I midified the file and packed again with apktool now google says that apk is not sincronized or domething like that :x :cry: :x
The question here is why gdevelop makes debuggable apks and the same with phonegap builder, maybe has to be with cordova :? :?
User avatar
By xisco
#70683 hi
just opened git issue last night. I've found some info.
I've struggled with the issue, found an utility to unpak apk, modified and then packed but then the message from google is that is not well signed, and I don't have the key to sign it, so I'm stuck until the problem is solved.
Seems that using cordova with --release option make a release apk and not debuggable, maybe is the solution.
I've set up cordova but something is not really working, will continue trying in the meantime :x