Pour vos problème ou demande d'aide concernant la création de jeux avec GDevelop.
User avatar
By Niko300
#63516 Ici j'ai fait juste une capture d'écran après 4 potions pour aller plus vite mais je me souviens bien que ramassage par ramassage ce n'est ni plus ni moins qu'une progression dans les assignements de variable.
Début : T0=0 | T1= 0 | T2=0 | Q0=0 | Q1=0 | Q2=0 | LPP=0
1ère potion : T0=2 | T1= 0 | T2=0 | Q0=1 | Q1=0 | Q2=0 | LPP=1
2ème potion : T0=2 | T1= 0 | T2=0 | Q0=1 | Q1=1 | Q2=0 | LPP=2
3ème potion : T0=2 | T1= 0 | T2=1 | Q0=1 | Q1=1 | Q2=1 | LPP=3
4ème potion : T0=2 | T1= 0 | T2=1 | Q0=1 | Q1=1 | Q2=1 | LPP=4

Je vais vérifier si je ne remet pas la variable Inventaire.1.type (T1) à zéro au cours de l'exécution et je te tiens au jus :)
User avatar
By Niko300
#63579 UP !

J'ai essayé de renommer "Inventaire" en "Inventory" en recréant toute une nouvelle variable structurée : Sans succès
J'ai essayé de renommer "type" en "typee" pour le type 1 : Sans succès
J'ai donc essayé de renommer carrément le 1 en 5, donc "Inventory.1.type" est devenu "Inventory.5.type" et là magie mon deuxième type qui s'appelle dorénavant "Inventory.5.type" au lieu de "Inventory.1.type" ou "Inventaire.1.type" ou même "Inventaire.1.typee", fonctionne, il reçoit enfin sa foutue valeur de type plutôt que de rester à 0 tout le temps.

Je ne comprends pas et j'aimerais quand même trouver une solution pour numéroter le deuxième type avec l'indice "1".

Est-ce que quelqu'un qui s'y connait vraiment bien en GDevelop a une idée de ce problème ? C'est un bug du logiciel ? :?
User avatar
By Niko300
#63691 Misère ce logiciel est vraiment buggué... :x
Je refait le test mais cette fois ci en ramassant d'abord la potion de nage et ensuite la potion prototype et de nouveau le même problème, le deuxième type reste à 0.
J'ai du supprimer les événement de la potion prototype et copier-coller ceux de la potion de nage qui sont exactement les même (à part devoir mettre type 2 au lieu de 1 en les éditant) et là ça marche alors que ce sont EXACTEMENT les mêmes événements :|
J'espère qu'il y aura bientôt une mise à jour pour optimiser le logiciel.
By Kink
#63704 humm, autant j'ai vu des bugs sur certains trucs, mais sur des manipulations de variables.. Si ça marche avec exactement avec les mêmes événements dans un contexte et pas dans un autre (dans ton projet où bcp d'autres events sont présents), c'est que d'autres events perturbent l'algo. Impossible à déterminer sans tout avoir.

Vérifies que tu n'as pas d'autres events qui modifient et feraient rester ta var à une valeur que tu ne souhaites pas.