Post here if you encounter any bugs.
By MobileNoob
#64133 Hi Folks,
I have been enjoying learning GDevelop, however I have an annoying bug that I can't seem to shake.

No matter what I do when I export a game (even the demo platformer) and upload it to my S5 Mini, the screen flickers (game window to black) for about three seconds and then stays black.

This is true if I use PhoneGap Build (apk) or PhoneGap App for testing.

Any ideas ?

Thanks
By MobileNoob
#64267 Hi again Folks,
I have done some testing with Phone Gap Desktop, and when I create the standard hello world app and test it with Phone Gap App on my S5 there is no screen flicker then black screen.

This means there is something going wrong with the GDevelop build process that is different to Phone Gap. Even the built in platformer is doing it.

Given that I can see the screen of my app for four or five seconds whilst it flickers, it feels like a video memory buffer error. I have tried to limit the frame rate and put a low max frame rate on, all of the tweaks I have tried fail.

I have tried using the config.xml from the Phone Gap hello world demo and that fails as well.

I am at a bit of an end because if my builds with Phone Gap don't actually work on (my) real hardware, my confidence in GDevelop takes a bit of a hit.

I am willing to try any suggestions to try and fix this.

Thanks

MobileNoob
By MobileNoob
#64309 Ok so I have been trying everything I can think of to solve this.

Today I setup a cocoon account, after I saw that it was one of the build types about to be documented on the wiki.

Success with the Webviewer+ Engine on my Galaxy S5 Mini, but for a 4MB app it added another 24MB.
+++ An Update: The standard Webviewer (not plus) Engine, illicits the same error as Phone Gap.

However there is no screen flicker and the app is working.

I would still prefer to use Phonegap if we can get this screen flickering sorted.

MobileNoob